MENU

关于WIN2003 内存加载DLL

September 14, 2021 • Epl

分享一个能在2003系统,内存加载DLL的模块函数,试了几个都崩溃
调用方式,在 _启动子程序 或者 启动窗口_创建完毕 下面直第一行 设定进程DEP保护() 即可

内存加载,DLL最好不要压缩
如果压缩了一定要用解压缩模块,压缩后放进资源,内存载入的时候记得解压一下

.版本 2

.子程序 设定进程DEP保护, 逻辑型, , 数据执行保护开关。成功返回真,失败返回假
.参数 dwFlags, 整数型, 可空, 如果DEP系统策略为OptIn或OptOut并且为该进程启用了DEP,则将dwFlags设置为0将禁用该进程的DEP。

.如果真 (GetSystemDEPPolicy () < 2)
    返回 (假)
.如果真结束
返回 (SetProcessDEPPolicy (dwFlags))

.版本 2

.DLL命令 SetProcessDEPPolicy, 逻辑型, "KERNEL32.DLL", "SetProcessDEPPolicy"
    .参数 dwFlags, 整数型

.DLL命令 GetSystemDEPPolicy, 整数型, "KERNEL32.DLL", "GetSystemDEPPolicy"

如果编译提示:指定Dll命令名称“SetProcessDEPPolicy”未找到
请尽量使用正版易语言,否则DLL粘贴进去会提示未找到,虽然正版有时候也有这个问题

Archives QR Code
QR Code for this page
Tipping QR Code

感谢以下平台提供云加速支持