MENU

易语言检测端口是否被占用

September 5, 2021 • Epl

端口.png

.版本 2

.子程序 端口_是否被占用, 逻辑型, , 被占用返回真,失败返回假
.参数 端口, 整数型
.局部变量 data, 文本型
.局部变量 result, 整数型

data = 系统_取DOS执行结果 (“netstat -ano|find ” + #引号 + “127.0.0.1:” + 到文本 (端口) + #引号)
data = 文本_取右边 (data, “ ”)
result = 到整数 (data)
返回 (取反 (result = 0))  ' 无占用返回0,#被占用返回PID

调用了精益模块噢,自行下载!~~

Archives QR Code
QR Code for this page
Tipping QR Code

感谢以下平台提供云加速支持